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We’re the Macomb Intermediate School District.  We exist to provide our clients quality service, high 
caliber support and cutting edge leadership. 
 
Our primary clients are the 21 school districts of Macomb County.  They are our most important 
customers--indeed, our reason for being. 
 
Within these districts we focus our efforts on school staff.  We work to increase their skills and capabilities 
so their students can experience more effective educational programs. 
 
We also serve students with disabilities.  In fact, we are committed to working directly with youngsters with 
disabilities who reside in Macomb County’s school districts. 
 
And we are involved with the educational community across the country.  Many of our staff members are 
deeply involved in state and national programs.  Many are working with colleges and universities.  Still 
others are exchanging information with their professional colleagues.  All these activities have a single 
purpose:  to identify and develop techniques and programs which improve learning opportunities in 
Macomb County. 
 
This is the professional focus which makes the Macomb Intermediate School District one of America’s 
premier regional education agencies. 

 
 

The MISD is an equal opportunity employer.  It is the policy of the MISD that no person on the 
basis of race, creed, color, religion, national origin, age, sex, height, weight, marital status, or 
disability shall be discriminated against, excluded from participation in, denied the benefits of, or 
otherwise be subjected to discrimination in any program or activity for which the MISD is 
responsible. 

 
The MISD will provide, upon request with advance notice, appropriate auxiliary aids and 
services necessary to afford a qualified individual with a disability equal opportunity to participate 
in the services, programs and activities conducted by the MISD.  To request auxiliary aids or 
services, contact Rosetta Mullen, 586/228-3309.  MISD Text Telephone (TTY) 586/286-8040. 
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To Start and Login to SASI: 
 

• Double-click on the SASIxp icon. 
 
• Type your SASI User ID  

 
• Tab to the Password field 

 
• Click on the Login button OR press the Enter/Return key 

 

To Exit SASI: 
 

• From the File menu, select Quit 

 
To Change your Password: 
 

• Enter your current User ID and Password 
 

• Click the Change Password button 
 

• Enter your new password 
 

• Re-enter the new password 
 

• Click Change button 
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SASI Desktop 
 

 

 

         

 

 

• Title Bar – denotes the active window/program as recognized by the system 

• Menu Bar – displays options for use within the system and displays menus for each active 
application atom. 

o File Menu Options: New Folder, Open, Close, View By Name/Icon, Atom/Form Info, 
Duplicate, Install Atom, Save Data/Desktop, Find Atom, Find Atom Again, Page 
Setup, Print, Clean Eraser on Desktop, Quit 

o Edit Menu Functions: Undo, Cut, Copy, Paste, Clear, Select All 

o Windows Menu Functions: Arrange Windows, Names of Open Folders and Atoms 

o Data Menu Functions: Find, Add, Delete, Inactivate, Next, Previous, Sort List, Reset 
Columns Width, Export List, Graph, Hide/Show Item Boxes, Hide/Show Control 
Buttons 

Title Bar 

Toolbar 
Title Box 

Toolbar
Docking 
Bays 

Screen Lock 

Data Lock 

Information Bay 1 

Status Bar

Eraser

Message 
Center

Information Bay 2 Information Bays 3 & 4 

System Filter 
Folder 

In Folder

 
Folders 

 
Atoms 

SASI Modules 
Globe 

Menu Bar 
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o Atom Menu Options: Atom menus list the functions and reports available for specific 
atoms. These atom-specific menus display in the menu bar when an atom is opened 
and change as you open different atoms. 

o Help Menu Options: SASI software Help, Online Documentaiton 

• SASI Modules Globe – contains the folders and application atoms 

• Folders – storage areas for atoms and other folders 

• Atoms – runs applications and displays data 

• In Folder – receives atoms from other users over the network 

• System Filter Folder – contains active filter atoms 

• Eraser – removes folders, atoms, and atom aliases from the desktop 

• Message Center – contains four information bays, status bar, mini pic, xp icon. 

o Information Bay 1 - will give detailed description of whatever the mouse arrow is 
pointing at. 

o Information Bay 2 – will display one of 3 functions: states the name of the SASI 
license holder; gives a red warning bar with an error message if a problem is 
encountered by the system; a progress bar appears during long thinking processes. 

o Information Bays 3 & 4 – can be used to hold data information. You can select up to 
four data fields to be used (two in each bay). To select fields for information bay: open 
an atom, click and hold any available data field in the form, a dotted line displays 
around the selected field, drag the dotted outline over one of the information bay fields 
and drop it there. To replace fields for information bay: simply drag and drop over 
existing field. To remove fields from information bay: use your mouse and right click 
each field you want to remove or hold down the Alt key and left click the mouse 
button. 

o Status Bar – displays the name of the school, number of the school, school year 
currently selected, user ID for the user that is currently logged in, and current date. 

• Screen Lock – click this icon to hide the SASI software desktop behind a lockout screen so 
that data can not be viewed. To unlock the screen, enter your password in the field provided 
and click OK. 

• Data Lock – click this icon to put all data fields in view only mode so that data can not be 
entered or accidentally changed. To unlock data, click this icon again, enter your password in 
the dialog box provided, click OK. 

• Toolbar – displays on the left side of the desktop. It provides a place to store aliases for atoms 
that you use frequently so that the atoms are easy to find and readily accessible. An alias 
represents an atom that is stored elsewhere on the desktop. 

o Toolbar Title Box – contains a pop-up list of toolbar options 
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o Docking Bays – area to store atom aliases  

SASI Toolbar 
 
To create a toolbar: 
 

• From the Toolbar Selection Box, select the New Toolbar option. The system displays a 
window for naming the toolbar. 

• In the Enter New Toolbar Name: field, type a name for the new toolbar. 

• Click OK to create and save the new toolbar. The new toolbar displays with empty areas. 

To add an atom to the toolbar: 
 

• Click the atom, then drag and drop it into any empty bay on the toolbar. 
 
To remove an atom from the toolbar: 
 

• Hold down your Alt key and click the atom that you want to remove, then drag and drop it on 
top of the Eraser on your desktop. 

 
To rename a toolbar: 
 

• From the Toolbar Selection Box, select the Rename Toolbar option. The system displays a 
window for renaming the toolbar.  

• Type a new name for the new toolbar. 

• Click OK to save the new toolbar name. 

To empty a toolbar: 
 

• From the Toolbar Selection Box, select the Empty Toolbar option. The system removes all 
aliases from the toolbar but retains the name of the toolbar.  

To delete a toolbar: 
 

• From the Toolbar Selection Box, select the Delete Toolbar option. The system removes the 
toolbar contents and name so that they are no longer accessible.   

Note: the system will not allow you to delete the last toolbar, (only empty). 

 
Tip: Save your desktop by choosing Save Desktop from the Menu bar or use 
Ctrl + S.
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Toolbar Exercise 
 

1. Create a new toolbar named “Student.” 
 
2. Open the SASI Modules Globe. 

 
3. Open the Student Info folder. 

 
4. Create atom aliases in the new toolbar for these atoms: 

• Enrollment atom 
• Student atom 
• Parent Guardian atom 

 
5. Remove the Enrollment atom alias from the toolbar. 

 
6. Display another toolbar. 

 
7. Open the Student atom from the toolbar. 

 
8. Close the Student atom using the close box in the title bar. 

 
9. Empty the toolbar named “Student.” 

 
10. Delete the toolbar named “Student.” 
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Creating Folders 
 
You can create an unlimited number of folders in the SASI system, and you can use  folders for many 
purposes. For example, you can use folders to store different types of atoms (data, report, query, or filter 
atoms). You can move folders that you create within the workspace and you can copy atoms into them. 

To create a new folder: 
 

• From the File menu, select the New Folder option. The system displays the window for creating 
folders. 

• In the top field of the window, select a folder storage area from the list. 

• In the Save as field, type a name for the new folder. 

• Click Save to create and save the new folder (or click Cancel to discard the folder). A briefcase icon for 
your new folder displays in the selected storage area. 

• Click the new folder then go to the File menu and select the Atom Info option. From this option, you can 
rename the folder if desired, enter a folder description, assign a Hot Key, or lock the folder. 

To add or copy atoms to an open folder: 
 
Click the atom that you want to add to the open folder, then drag and drop it into the folder. If you want to add a 
copy of an atom to the open folder, hold the Alt key then click the atom, and drag and drop it into the open 
folder. The original atom remains unaffected while a copy is stored in your folder. 

To add atoms to a closed folder: 
 
Click the atom that you want to add to the closed folder, and then drag it over the folder icon until the folder icon 
is highlighted. Drop the atom onto the folder when four arrows point to the folder’s center to indicate that the 
item is positioned correctly over the folder. 

To erase a folder: 
 

• Click and hold the folder that you want to delete. 

• Drag and drop the folder over the Eraser icon in the lower right corner of the workspace. The Eraser 
moves back and forth as chalk dust displays, and the system places the selected folder in the Eraser 
folder. 

• To restore an erased folder, double-click the Eraser folder. From the Eraser folder, select the folder 
that you want to restore, then drag and drop it back into the workspace. (Any items that you leave in 
the Eraser folder remain there until you permanently delete them even as you log in to, and out of, the 
system). 

• To permanently delete the erased folder, go to the File menu and select the Clean Eraser option. The 
system permanently deletes all items in the Eraser folder. 
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Screen Elements 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Photo box – Displays a photo in the student, teacher, and staff screens. 

• Forward/back arrows – Enable you to advance forward or backward through individual 
records displayed in a screen. 

• Data field – Displays data in atom screens 

• Title bar – Displays at the top of open atom window with the atom name and the name of any 
record displayed.  

• Pop-up lists – contain program-defined values or school-defined values for an atom field. 

• Close button – Closes an atom screen with one click 

• Find button – starts the find function, which enables you to display one or more records that 
match criteria you define. 

Note:  to close multiple open windows, hold down the Alt key and click the red “X” in the upper right 
corner of a window. 

Forward/Back Arrows 
Title Bar 

Data 

Photo 
Box 

Forward/
Back 
Arrows 

Find 
Button 

Close 
Button

Pop-up 
Lists 

Close Button 
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To Find Information Within SASI 
 

• Go into Find mode by clicking on the “magnifying glass” 
 
• Enter search Parameters 

 
• To activate the Find process, click on the Find Action Button. 

 
Using wild cards: 
 

• * Asterisk – If entering an Asterisk in a field or at the end of a name, the system will find all of 
the entries that match the request.  E.g. Entering “Smith*” in the Last Name field, will give you 
a matrix of all of the students with the last name of Smith.  Putting an “ * ” in the Ethnic Code 
field will bring up the Ethnic codes related to each child. 

 
• : Colon – Entering a Colon before a search parameter will cause the system to find each entry 

that contains the stipulated criteria.  E.g. Entering “:Oak” in the Address field, will find all of the 
students whose address contains the word Oak. 

 
• < Less Than – Entering a Less Than symbol in a field along with an established value, will 

give you a listing of each occurrence that falls prior to the established value.  E.g. Entering 
“<010182” in the Birthdate field will give you a list of each of the students who were born 
before 1982. 

 
• > Greater Than – Using the Greater Than symbol is similar to the Less Than symbol 

described above. 
 

• |- Begins With – (This symbol is a combination of a Pipe “|” typed with a Dash”-“.)  Entering a 
Begins With symbol before an established value will find you all entries that begin with that 
value.  E.g. Entering “|-93” in the Zip Code field will find all of the students whose zip code 
begins with the numbers 93. 

 
• -| Ends With - (This symbol is a combination of a Dash”-“ typed with a Pipe “|”.)   Using the 

Ends With symbol is similar to the Begins With symbol described above. 
 
 
 
 
 
Note:  Due to certain programming requirements, some fields may not acknowledge all wild card 

commands.  Simply try the command, and check your results. 
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Elements of a Matrix  
 

 

 

 

 

 

 

 

 

 

 

To sort records in a matrix: 
Sort records in a matrix by ascending and descending order in one column or multiple columns. 

• Single Sort – double-click a column heading 
• Reverse Sort – hold down the Alt key and double-click a column heading 
• Multiple Sort - hold down the Shift key and click each column heading in the order in which 

you want to sort.  From the Data menu, select the Sort List option or double-click the last 
column selected. The matrix list displays records sorted in ascending order by each column in 
the order you selected them. 

 
To export  a matrix: 
From the Data Menu, select Export List, name and save the file, can open file in another application.

Status: displays if a 
student’s status is 
Active/Inactive/No Show. 

To deselect 
highlighted 
rows and 
columns:  
Click once on 
the Student ID 
column 
heading. 

To Resize a Matrix:  
Each column has the ability to be narrowed or expanded. 
Just place your mouse arrow on the column dividing line 
between columns and when original arrow turns into a 
double directional arrow drag to the right or left. 
 
Click on the Resize button that displays in the lower right 
corner of the matrix (under or next to a scroll bar) then 
drag the mouse in the direction that you want to enlarge 
or shrink the matrix. 

To Select a Column 
of Information: 
Click once on the 
column heading 

Elevator 
Box  

Scroll  
Bar  

Resize  
Box  

Action 
Button  

Tally of Records Found:  
This will be displayed only if all records have been acknowledged by the system.   
 
To acknowledge all records, either: 
1) Scroll to the bottom of the matrix with the down arrow. 
2) Sort a Column (e.g. Last Name) by double-clicking on the column heading. 
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To generate graphs: 
 

• One category from a Matrix 
o Select the column that you wish to be the baseline on the graph (X-axis) 
o From the Data menu bar, select Graph. 

 
• More than one category from a Matrix  

o Select one column that you wish to be the baseline on the graph (X-axis). 
o Hold down your Shift key (this is again the “and” of the process you are telling the 

system to perform.) 
o Select a second column by clicking once on the column heading. 
o From the Data menu bar, select Graph. 

 
To print a graph: 
 

• Click on the File menu bar and select the Print option. 
 

Graph Type: 
choose from Bar, 
Line, Line-Box or 
Pie Chart. 

Title Bar: reflects 
the columns that 
were selected to be 
graphed, and the 
order in which they 
were selected if 
there was more 
than one. 

Graphing Matrixes 
(Information can only be graphed from a matrix) 

Auto Scale : enables you to scale a graph automatically. Flags: displays a break down of the 
numbers for a selected category.   
(there are 183 male students in the 
school out of a total 370 students.) 
To Create Flags: 
Click once on a category.  
To Clear Flags: 
Select the Radio Button for the graph 
again. 

Legend: show or 
remove a legend to 
display in the upper 
right part of the 
graph or position 
On Graph. 
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Enrollment Atom 
 

You must enroll students using the Enrollment atom (in the Student Info folder) before you can enter 
student information or use other student-related functions in SASI. 

As you enter and save basic data, SASI automatically creates the Student records and Attendance 
records where you can enter data for each enrolled student.  You can create records in other student-
related atoms as needed. 

The Enrollment atom consists of two pages:                                                                                                                      

• Current  

• Enrollment History 

Current: 
 
The Current screen enables you to add students, inactivate students, and update enrollment records 
with the latest changes in a student’s enrollment status. 

 

 

 

 

 

 

 

 

 

Note: The following mandatory fields must be completed to Save the Enrollment Record:  Last 
Name, First Name, Grade, Gender, Student ID, Enter Date, and Enter Code.    
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Enrollment information and history will impact the accuracy of attendance and membership reports.  It 
is important that the following fields are entered accurately.   

• Enter Date – Most recent date the student enrolled at your school.  The system records any 
previous enrollment dates in the Enrollment History matrix.   

• Enter Code – Code indicating the circumstances under which a student enrolled at your 
school. If a default code has been defined in the School atom, this displays here automatically 
when you enroll a student. (ENT table) 

• Effective Date – The date that a change to a student’s enrollment status becomes effective.  
When you enroll or inactivate a student, the date in the Enter Date or Leave Date field is 
entered automatically in the Effective Date field.   

• ADA – Enables you to indicate a student’s eligibility for ADA.  The system defaults to Yes. 

o Y indicates Yes.  

o N indicates No. 

o A indicates ½ day AM.  

o P indicates ½ day PM. 

o Concurrent means concurrently enrolled. This is used only for district integration. 

• No Show – not used in Macomb County 

• Tch – Teacher number for the teacher to whom a student is assigned. This can be the 
student’s advisor or homeroom teacher.  At Daily Attendance schools, this teacher’s class is 
the one used for attendance.  Teacher numbers entered here are automatically displayed in 
the student records in the Student atom.  This field displays only if it was selected in the 
School atom as a Data Change Affecting Enrollment. 
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Enrollment History: 
 
The Enrollment History screen enables you to review and revise each student’s complete enrollment record for 
a specific school year. 

In addition to enrolling students, you can use the Enrollment atom to update enrollment records with 
new data such as changes in teachers or instructional settings.  You can also work from this atom to 
revise enrollment histories, change the Name/ID line, and to inactivate, reactivate, or delete students. 

 

 

 

 

 

 

 

 

 

To enroll a new student: 
 

• Launch the Enrollment atom. 

• From the Data menu, select the Add Student option.  The number of the school you are 
logged into displays in the School field and the current date displays in the Enter Date field. 
(Asterisks display in the Student ID field if your school has set up this field for automatic entry 
of permanent numbers). 

• In the Last Name, First Name, and Middle Name fields, type the student’s name information.  

• In the Gnrtn field, select the appropriate generation indicator, if applicable (Jr., II, etc.). 

• In the Grd field, select the student’s grade from the pop-up list. 

• In the Gen field, select the student’s gender from the pop-up list. 

• Review the Enter Date field and change the default enrollment date if necessary.  

• In the Enter Code field, select a code from the pop-up list if the system does not automatically 
supply a default code. 

• In the IS field (if displayed), select an instructional setting from the pop-up list. 
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• In the Tch field (if displayed), click the Link Arrow to display the Teacher List from the Teacher 
List atom (this remains open). For subsequent students, click the Teacher List to move it in 
front of the Enrollment screen.  Drag and drop the teacher number to the Tch field. The 
teacher number displays and the system automatically enter a name in the Teacher Name 
field. 

• Skip the Effective Date field because the system automatically supplies data when you save 
the record. 

• Click Save to save the student enrollment record.  Saving the record automatically adds a line 
of history to the Enrollment History record and creates a record in the Student file and Daily or 
Period Attendance files. 

To revise enrollment history: 
 

• Launch the Enrollment atom and display the History matrix. 

• Locate the student record that you want. 

• From the Enrollment menu, select the Change Enrollment History option. 

• Click the matrix cell that requires change. Type new data or select a different item from the 
pop-up list. 

• Click Save to save the new data. 

To change Name/ID Line: 
 

• On Enrollment menu select Change Name…ID Info, this option unlocks the top line on the 
Current form of the enrollment atom so that you can make changes to data there (Last Name, 
First Name, Middle Name, Gender, and Student ID). Changes made using this option display 
in all records for a student. 

To delete a line of enrollment history: 
 

• Launch the Enrollment atom display the History matrix. 

• Locate the student record that you want. 

• From the Enrollment menu, select the Change Enrollment History option. 

• Click the line number (Ln) for the row of information to be deleted. Ensure that the row is 
highlighted. (The first row cannot be deleted because it displays a student’s original enter 
date). 

• From the Data menu, select Delete Enrollment Record to delete the highlighted row from the 
matrix. 

• Click Save to delete the enrollment record. 
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Inactivating and Deleting Students 
 
You can work from the Enrollment atom to delete, inactivate, or activate students using options on the 
Data menu. The Inactivate option on this menu changes to Activate when an inactive record is 
displayed. 

These data fields are required to inactivate a student:  Leave Date, Leave Code 

To inactivate a student record: 
 

• Launch the Enrollment atom and display the current screen. 

• Locate the student record that you want. 

• From the Data menu, select the Inactivate Student option. By default, the system enters the 
current date in the Leave Date field (but you can manually change the date). 

• In the Leave Code field, select a code from the pop-up list. The system may automatically 
enter a default leave code depending on your school’s setup. 

• Click Save to inactivate the student. In all Student atoms, parentheses display around a 
student’s name to indicate inactive status. 

If your school is setup as an elementary school with schedules or as a secondary school, the system 
displays a dialog box asking if you want to drop the student from all classes. 

To reactivate an inactive record: 
 

• Launch the Enrollment atom and display the Current screen. 

• Locate the student record that you want. 

• From the Data menu, select the Activate Student option. The system erases data in the Leave 
Date field. The system also enters the current date in the Enter Date field but you can change 
this manually if necessary. (The system maintains the student leave data and continues to 
display it in the Enrollment History screen). 

• In the Enter Code field, select a code from the pop-up list if the system does not automatically 
supply a default code. 

• Click Save to reactivate the student. In all Student atoms, parentheses disappear from around 
a student’s name to indicate active status. 



REVISED: 10/06 
N:\KFANDALE\MISD DOCUMENTATION AS OF FEB 2008\SASI BASIC APPLICATIONS (MISD).DOC 

19 

To delete a student record: 
 

• Launch the Enrollment atom and display the Current screen. 

Note:  The Delete function is available only from the Current screen in the Enrollment atom 
and is only available to users who are given the rights in the User atom. 

• Locate the student record that you want. 

• From the Data menu, select Delete Student. The system displays a dialog box with two 
buttons. 

• Click OK to delete the student form the system. All data associated with that student in all 
Student atoms is permanently removed.   

 
Fast Access Atoms 
 
The Enrollment atom also enables you to quickly access all the atoms that your school defines as 
important to maintaining essential student data. These atoms display in a list as Fast Access atoms on 
the bottom of the Enrollment form and can be launched via Link Arrows.   A student’s basic data must 
be saved from the Enrollment atom before you can work within other atoms to add information about 
the student. 
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Student Atom 
 
The Student atom enables you to enter, maintain, and view demographic data for students at your school. The 
Student atom consists of three pages and accepts information that becomes part of the student’s unique 
records. 

All fields within the pages of the student screen are optional. You can enter data depending on the 
information available and the needs of your school. Student labels, rosters, and reports are generated 
based on data from the student screen. You can return to the student screen as often as necessary to 
update data. 
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Parent Guardian Atom 
 
The Parent Guardian atom (in the Student Info folder) enables you to create, maintain, and view 
address and employment information for the primary parent or guardian for a student and for any 
additional adults responsible for a student.  

You can add as many parent/guardian records as needed for each student. The parent or guardian 
who assumes primary responsibility for the student should be added first since that parent/guardian 
record displays first by default. Subsequent parents and guardians may be added for adults such as 
non-custodial parents or step-parents. 

These data fields are required to enter parent/guardian data.  Relationship, Last Name, First Name 

You can use the Personal/Employment form to enter and view most information related to a student’s 
parents or guardian. 

 

• E/M - This represents extra mailings and indicates whether school mailings should be sent to 
an additional parent/guardian  

• Res - Indicates whether a student resides with the parent/guardian. This field defaults to X 
Student Resides Here when you add a record. 

• Rsp - Indicates whether the parent/guardian has primary responsibility for the student.  

• The multi-record selection bar displays the number of parents or guardians assigned to each 
student. The bar displays on the right side of both the Personal/Employment screen and the 
Comments screen in the Parent Guardian atom, and it provides you with quick access to all 
the parent guardian records for a student. Numbers for each parent/guardian are assigned in 
the order that the parents and guardians are added for the student. Use arrows to scroll 
through the parent/guardian records in consecutive order. 

• The Comments screen exists primarily so that you can record additional information (over 
32,000 characters) about a student’s parent or guardian. You might note custody 
arrangements, special family situations, or instructions regarding to whom a student can be 
released on this form. 
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Emergency Atom 
 
The Emergency atom (in the Health/Emergency folder) enables you to create, maintain, and view 
emergency records for a student.  A student emergency record contains all the medical alert and 
contact information necessary in case of a medical emergency.  

You can use the Emergency Contracts screen to enter and view most information related to a 
student’s medical conditions.  The Other Contacts screen can be used to enter third and fourth 
contacts, if necessary.  

 

The Emergency Information screen allows you to enter information about a student’s medical 
conditions and physician.  The large comment field accepts up to 32,000 characters.  You might 
elaborate on medical conditions, or note medications taken by a student.   
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Health Atom 
 
The Health atom (in the Health/ Emergency folder) enables you to create, maintain, and view health 
records for a student. A student’s health record contains data on all health-related incidents that occur 
at school or that affect a student’s attendance or performance at school. The health record also 
displays a record of required immunizations and vaccination dates for each student. The Health atom 
consists of five pages: 

• Health History Screen 
• Immunizations Screen 
• Medical Screen 
• Health Screenings Screen 
• Scoliosis Screening Screen 

 
Health History Screen: 
 
The Health History screen displays a row for each health-related incident that occurs at school or that 
affects a student’s attendance or school performance. 

 

Health History Detail Screen: 
 
The Health History Detail screen displays data related to a single health incident. The fields in this screen 
correspond to columns in the Health History matrix. The screen also includes a Comments field for additional 
incident information. You can access a health screen by double-clicking the line number of any record in the 
Health History detail screen. 

Note: By Using 
the Multi-Record 
Selection Bar 
you can get back 
and forth 
between health 
incidents. 
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Immunizations Screen: 
 
The Immunizations screen displays data related to separate immunization records. It includes a row for 
each immunization required for a particular student. The matrix allows a maximum of ten required 
dosages for any immunization type. If a dosage date cell is shaded, then a dosage is not required.  The 
number of unshaded date cells in a vaccination row indicates the number of required dosages.  
Immunization requirements are defined in the Vaccine Definition atom. 

Immunization Detail Screen: 
 
The Immunization Detail screen displays the data related to a single immunization record. This screen also 
includes a comments field for additional immunization information. You can access an immunization detail 
screen by double-clicking the line number of any record in the immunizations screen. 

Medical Screen: 
 
The Medical screen enables you to record information about tuberculosis skin tests. If a positive test is 
recorded it will give you an additional area to fill in regarding chest X-Rays. 

Health Screenings Screen: 
 
The Health Screening enables you to record information about screenings and referrals for vision and 
hearing. It also enables you to record height and weight information. 

Health Screening Detail Screen: 
 
The Health Screening Detail screen displays the data related to a single screening record. Most fields 
in this form correspond to columns in the Health Screening matrix. You can access a health screening 
form by double-clicking the line number of any record in Health Screening screen. 

Scoliosis Screening Screen: 
 
The Scoliosis screen is used to record information about Scoliosis X-Rays and Physical Exams. 
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Generic Selection Atom 
 
The Generic Selection atom (in the Utilities module) provides fast access to records for one or more files within 
a specific atom by displaying lists of student names based on your specified criteria. Once a student list 
displays, you can select the names of students for which you want to locate records then drag and drop the 
student names onto the Student atom icon to open their records simultaneously. 

Using the generic selection atom: 
 

• Launch the Generic Selection atom. 

• In the Search File field, select a search file from the pop-up list. 

• Locate the items you want to select. Either type the key data in the Locate field and press Enter or 
scroll until the item displays, then release the mouse so that the selection displays in the Available 
Selections list. 

• Transfer items from the Available Selections list to the Selections list using one of these methods: 

o Click to highlight one item or hold down the Shift key and highlight several items. Click the >> 
button. 

o Double-click each item you want to move. 

• To open records for the selected items, highlight all items in the Selections list. Drag and drop these 
items onto an atom icon. 

o Dropping a single item onto a closed atom icon opens the atom to the required record. 

o Dropping a single item onto an open atom icon closes the current record and opens the record 
for the item just dropped. 

o Dropping multiple items onto a closed atom icon displays a list containing the selected items 
(key data). You may open one record at a time or multiple records. To open a single record, 
double-click the item to display the data record. To open multiple records, highlight all items 
then click the Open key. Multiple records cascade in ascending order. 

o Dropping multiple items onto an open icon atom opens a screen for each record. Multiple 
records cascade in ascending order. Notice that the key data displays in the screen’s title bar 
to identify the record. To move a record to the front, click the title bar. 
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Student Groups Atom 
 
The Student Groups atom (in the Student Info folder) enables you to add students to groups such as marching 
band, girls’ basketball, or the National Honor Society. 

Organizing students into group lists enables you to run reports by group and to mass change attendance by 
group. For example, if the marching band is not present one day due to participation in a battle of the bands 
event, you can use the Mass Change Attendance function to mark records for all band members with Activity 
for that day. 

Once your school has set up a list of student groups in the Groups table (GRP) in the Tables Definition atom, 
you can add students to groups at anytime (at the beginning of the school year or as students join groups 
during the course of the year). 

Using the group’s matrix: 
 
The Groups matrix lists all students in a selected group. You can select different groups from the list in the 
Student Group field. Students are added to groups in alphabetical order, but you can resort them by Student ID, 
Start Date, or End Date fields by double clicking headings for these field columns.  

 

The Student Group field allows you to display a pop-up list including all the groups set up for your school in the 
Groups table (GRP) in the Tables Definition atom.  When you select a group from the list, participating students 
display.  The most efficient way to add students to a group is to identify them from the Generic Selection atom. 
You can also drag and drop one or more students from anywhere in the system, including a matrix produced by 
a Find or Query. 
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To add students to a group: 
 

• Launch the Student Groups atom. 

• In the Student Group field, select a group from the pop-up list. The system automatically enters the 
current date in the Default Date field which represents the start date for all students you are about to 
enter (you can change this date). 

• Add students using one of these methods: 

o Launch the Generic Selection atom. Click and highlight one student record or hold down the 
Shift key and click and highlight multiple records. Then click the arrow to put selected students 
on the Selections list. (You can also put students on this list by double-clicking their records). 
Click the Selections list heading to highlight all students on the list. Drag and drop the list onto 
the Student Groups matrix. Click done in the Generic Selections atom. 

o Produce a matrix of student names using a Find or Query. Click and highlight one student 
record or hold down the Shift key and click and highlight multiple records. Drag and drop the 
selected records onto the Student Groups matrix. 

• Save to save group additions. 

To inactivate students in a group: 
 

• Launch the Student Groups atom. 

• In the Student Group field, select a group from the pop-up list. The system automatically enters the 
current date in the Default Date field which represents the end date for all students that you inactivate 
(you can change this date). 

• Click the Student ID number of the student to be inactivated. Ensure that the row is highlighted. (To 
select multiple students, hold down the Shift key and click student ID numbers). 

• From the Data menu, select the inactivate Student option. The system automatically enters the 
specified default date in the End Date field for each selected student. 

• Click Save to save to inactivate students. 

To delete students from a group: 
 

• Launch the Student Groups atom. 

• In the Student Group field, select a group from the pop-up list. 

• Click the Student ID number for the student to be deleted. Ensure that the row is highlighted. (To select 
multiple students, hold down the Shift key and click student ID numbers). 

• From the Data menu, select the Delete Student option. The system removes the records of all selected 
students. 

• Click Save to delete the students’ group records. 
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Phone Numbers Atom 
 
The Phone Numbers atom (in the Student Info folder) enables you to quickly locate student telephone numbers. 
This view-only atom displays a matrix including all phone numbers (including parent/guardian numbers and 
emergency contacts) that are available for a student. 

 
Viewing the phone numbers matrix: 
 
You must display a student record in another atom before the Phone Numbers matrix displays any data (it 
remains blank). If you have multiple student records open in other atoms then open the phone numbers atom, 
the matrix displays the numbers for the most recently active student record (the one in which you were just 
working). If you leave the Phone Numbers atom open while working in other atoms, the phone numbers matrix 
displays the numbers for the record in the active atom. 

If you double-click anywhere in a row within the Phone Numbers matrix, the system launches the atom in which 
the phone number is stored (for example, the Parent Guardian atom). When the atom containing the original 
phone record is open, you can edit phone number information for the student record. When you save and close 
that atom, the system returns you to the Phone Numbers matrix which displays the new phone number 
information. 
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Student Distribution Atom 
 
The Student Distribution atom (in the Student Info folder) enables you to check the current student distribution 
(or enrollment total) for the entire student body. This view-only atom can display distribution totals by grade level 
and gender. Data is presented in a matrix and on a bar graph. You cannot modify enrollment totals from this 
atom. This atom provides a feature which enables you to export distribution data from the system for use with 
other applications. 

  

When you launch the Student Distribution atom, the system scans the student database to determine current 
enrollment totals. The system displays a message asking you to wait while this occurs.  The matrix on the 
student distribution form displays distribution numbers and totals. For each grade, the matrix displays the 
number of male and female students as well as the total enrollment for that grade. The matrix also displays the 
number of males and females among the entire student body.  Finally, the matrix displays the total current 
enrollment for the entire student body. 

• Bar Graph - The bar graph on the Student Distribution form displays a bar for the total number of males 
and the total number of females in each grade. The bottom axis indicates grade, and the side axis 
indicates student numbers. The legend indicates which color represents which gender. 

• Load From Date - When you click the Load from Date button, the system displays a dialog box 
prompting you to Date enter a specific date for loading enrollment totals. Enter a date then click OK to 
load enrollment data (or click Cancel to cancel the function). 
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A few more useful atoms are listed below. Please refer to 
the Pearson documentation located at the end of this 
handout for detailed information. 
 
Important! Be sure and consult with your district SASI 
coordinator regarding the usage of these atoms. 
 
 
 
Sibling atom – (in the Student Info folder \ Sibling atom) 
 
Discipline atom – (in the Discipline folder) 
 
Conference atom (in the Student Info folder) 
 
Fee atom (in the Student Info folder) 
 
Schools Attended (in the Student Info folder) 
 



REVISED: 10/06 
N:\KFANDALE\MISD DOCUMENTATION AS OF FEB 2008\SASI BASIC APPLICATIONS (MISD).DOC 

32 

Running Reports 
 
Many SASIxp application menus contain options to create reports. Reports may vary among atoms, 
and the atom from which you run a report determines what kind of information can display in the report. 
Typically, you define parameters such as student grade and gender or effective dates for the report 
that you want to create. The system produces generic reports and, from many atoms, enables you to 
create customized reports that you can save and use again later. (Please refer to the Pearson 
documentation located at the end of this handout for detailed information). 
 
MISD Enhancements 
The enhancements were created to fulfill a need in Macomb County. SASI might do a similar 
report but doesn't give all the information needed or the sort options that would be beneficial.  
Some of the MISD Enhancements that you might find helpful might be: 

• STU701x – Youngest/Oldest and Only Mailing Labels 

• STU730x – Class List Forms 

• STU740x – Student Transfer Sheet 

• DIS701x – Discipline Summary Report 

• DIS702x – Zero Tolerance Survey Totals Report 

Installing an Enhancement Atom: 

• Open SASIxp 

• From the Menu bar click on File 

• Choose Install Atom… 

• Browse to where your enhancements are located and select the enhancement you want to install and 
click Open or double-click the atom. 

• Are you sure you want to install an external file?  Click OK. 

• Enhancement will be installed on your SASI desktop. Double-click to use. 

• Remember to save your desktop after installing an enhancement(s). From the Menu bar choose Save 
Desktop or use Ctrl+S. 

 

The MISD has written many, many enhancements. Find out more on our SASI web page: 

http://www.misd.net  -- under District Support, choose Technology, choose SASI 
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